No announcement yet.

I wrote an Ansible playbook to get mDNS working with Untangle

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by willquill View Post
    First, I responded to your GitHub issue. Thank you for creating it there! That will help others find the info more easily.

    Here's what I posted to GitHub:

    With regard to this - "I'm not able to ping across my subnets still." - that is expected behavior, as my playbook only enables mDNS on the various interfaces. It does not create any firewall rules or allow any specific TCP/UDP ports or ICMP traffic. You should be able to get ping working across the subnets with a firewall rule or a filter rule in Config > Network > Filter Rules that allows the ICMP protocol between subnets.

    Ping uses the ICMP protocol and operates at layer 3, so it wouldn't have anything to do with VLANs, specifically - it only cares about subnets, like allowing ICMP from to There's no way to allow ICMP from "VLAN 10 to VLAN 69" as VLANs operate at layer 2 via tagged frames (as opposed to network packets).
    Yup, I understand what a ping is. You misunderstand my test. My test was to see if mdns discovery worked. Simple as that. ping blah.local from different subnets resulted in a response indicating it could not resolve the hostname. Switch subnets, ping blah.local worked fine, and I could see the traffic in a pcap. This told me mdns wasn't working. Nothing to do with the ping, but it's a perfect way to see if the hostname resolution was working.

    When I finally got avahi working on a linux box, the exact same test worked.