No announcement yet.

16.0.1 Upgrade Fails

  • Filter
  • Time
  • Show
Clear All
new posts

  • 16.0.1 Upgrade Fails

    I have an older U50 appliance that was preinstalled with 32 bit. Did a backup, re-install of 16.0.1 with 64 bit, restored the backup and verified automatic updates are enabled. The box never updates. Manually updating from the GUI yields the error: cannot download packages.

    /var/log/uvm/upgrade.log doesn't have anything particularly useful.

    Tried running manually to see what's going on. Below is what I'm seeing. It appears that apt is trying to hit the stable-160 repository that for some reason no longer exists. I *think* that if I change /etc/apt/sources.list.d from stable-160 to 16.0.1 it might work. Can anyone comment?

    I'd really rather upgrade this thing than go back out and re-install the latest version and redo the firewall. If anyone has a fix for this, I appreciate it.

    # /usr/share/untangle/bin/
    2023-02-09 07:30
    Checking if /var/lib/dpkg/available exists...
    /var/lib/dpkg/available exists.
    apt-get update  --yes --force-yes --allow-releaseinfo-change
    Err:1 stable-160 InRelease
    Connection failed [IP: 80]
    Reading package lists...
    W: --force-yes is deprecated, use one of the options starting with --allow instead.
    W: Failed to fetch  Connection failed [IP: 80]
    W: Some index files failed to download. They have been ignored, or old ones used instead.
    2023-02-09 07:31
    apt-get dist-upgrade  -o DPkg::Options::=--force-confnew -o DPkg::Options::=--force-confmiss --yes --force-yes --fix-broken --purge -o Debug::Pkgproblemresolver=1 -o Debug::Pkgpolicy=1
    Reading package lists...
    Prio of /var/lib/dpkg/status 100
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_non-free_binary-amd64_Packages 500
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_main_binary-amd64_Packages 500
    Prio of /var/lib/dpkg/status 100
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_non-free_binary-amd64_Packages 500
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_main_binary-amd64_Packages 500
    Prio of /var/lib/dpkg/status 100
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_non-free_binary-amd64_Packages 999
    Prio of /var/lib/apt/lists/updates.untangle.com_public_buster_dists_stable-160_main_binary-amd64_Packages 999
    Building dependency tree...
    Reading state information...
    Calculating upgrade...Starting pkgProblemResolver with broken count: 1
    Starting 2 pkgProblemResolver with broken count: 1
    Investigating (0) untangle-linux-config:amd64 < -> @ii umU Ib >
    Broken untangle-linux-config:amd64 Conflicts on linux-headers-4.19.0-8-untangle-amd64:amd64 < 4.19.98-1+untangle4buster @ii mK >
    Considering linux-headers-4.19.0-8-untangle-amd64:amd64 -3 as a solution to untangle-linux-config:amd64 0
    Added linux-headers-4.19.0-8-untangle-amd64:amd64 to the remove list
    Fixing untangle-linux-config:amd64 via remove of linux-headers-4.19.0-8-untangle-amd64:amd64
    The following package was automatically installed and is no longer required:
    Use 'apt autoremove' to remove it.
    The following packages will be REMOVED:
    The following NEW packages will be installed:
    linux-headers-4.19.0-11-untangle-amd64 linux-image-4.19.0-11-untangle-amd64
    The following packages will be upgraded:
    drive iptables libdebconfclient0 libfreetype6 libip4tc0 libip6tc0 libiptc0
    libmariadb3 libxtables12 linux-compiler-gcc-8-x86 linux-kbuild-4.19
    linux-libc-dev mariadb-common miniupnpd untangle-apache2-config
    untangle-app-ad-blocker untangle-app-application-control
    untangle-app-application-control-lite untangle-app-bandwidth-control
    untangle-app-branding-manager untangle-app-captive-portal
    untangle-app-configuration-backup untangle-app-directory-connector
    untangle-app-firewall untangle-app-ftp untangle-app-http
    untangle-app-intrusion-prevention untangle-app-ipsec-vpn
    untangle-app-license untangle-app-live-support untangle-app-openvpn
    untangle-app-phish-blocker untangle-app-policy-manager untangle-app-reports
    untangle-app-router untangle-app-shield untangle-app-smtp
    untangle-app-spam-blocker untangle-app-spam-blocker-lite
    untangle-app-ssl-inspector untangle-app-threat-prevention
    untangle-app-tunnel-vpn untangle-app-virus-blocker
    untangle-app-virus-blocker-lite untangle-app-wan-balancer
    untangle-app-wan-failover untangle-app-web-cache untangle-app-web-filter
    untangle-app-web-monitor untangle-app-webroot untangle-app-wireguard-vpn
    untangle-archive-keyring untangle-base-spam-blocker
    untangle-base-virus-blocker untangle-base-web-filter untangle-bctid
    untangle-bdamserver untangle-bootsplash untangle-clamav-config
    untangle-classd untangle-client-local untangle-database-config
    untangle-ddclient-config untangle-debconf-manager
    untangle-development-runtime untangle-exim4-config untangle-extjs
    untangle-gateway untangle-geoip-database untangle-google-connector
    untangle-hardware-config untangle-kernel-modules-buster-amd64 untangle-kiosk
    untangle-libuvm untangle-libuvmcore untangle-libuvmthirdparty
    untangle-linux-config untangle-lxc-client untangle-nflogd
    untangle-nsis-addons untangle-postgresql-config untangle-pyconnector
    untangle-python3-runtests untangle-python3-sync-settings untangle-root
    untangle-snmpd-config untangle-softflowd-config untangle-spamassassin-update
    untangle-spamcatd untangle-squid-config untangle-stunnel-config
    untangle-suricata-config untangle-sync-settings untangle-system-config
    untangle-update-manager untangle-vm wireguard-dkms wireguard-tools
    98 upgraded, 3 newly installed, 1 to remove and 0 not upgraded.
    Need to get 159 MB of archives.
    After this operation, 303 MB of additional disk space will be used.
    Err:1 stable-160/main amd64 linux-image-4.19.0-11-untangle-amd64 amd64 4.19.146-1+untangle1buster
    Connection failed [IP: 80]
    Err:2 stable-160/main amd64 linux-headers-4.19.0-11-common-untangle all 4.19.146-1+untangle1buster
    Connection failed [IP: 80]
    Err:3 stable-160/main amd64 linux-kbuild-4.19 amd64 4.19.152-1
    Connection failed [IP: 80]
    Get:4 stable-160/main amd64 linux-compiler-gcc-8-x86 amd64 4.19.152-1 [484 kB]
    Get:5 stable-160/main amd64 linux-headers-4.19.0-11-untangle-amd64 amd64 4.19.146-1+untangle1buster [956 kB]
    Err:6 stable-160/main amd64 untangle-hardware-config all
    Connection failed [IP: 80]
    Err:7 stable-160/main amd64 untangle-bootsplash all
    Connection failed [IP: 80]
    Err:8 stable-160/main amd64 untangle-kernel-modules-buster-amd64 amd64
    Connection failed [IP: 80]
    Get:9 stable-160/main amd64 untangle-linux-config amd64 [229 kB]
    Get:10 stable-160/main amd64 untangle-debconf-manager all [2,740 B]
    Err:11 stable-160/main amd64 untangle-pyconnector all
    Connection failed [IP: 80]
    Err:12 stable-160/main amd64 iptables amd64 1.8.2+
    Connection failed [IP: 80]
    Err:13 stable-160/main amd64 libxtables12 amd64 1.8.2+
    Connection failed [IP: 80]​

  • #2
    Don't change sources.list. In practice, everything in that file should be commented out.

    You can try changing /etc/apt/sources.list.d/utnangle.list, but I'd use 16.1.1 instead. Change the pointer back to stable-161 after it upgrades.

    If that doesn't work, drop Support an email with your UID and they can take a look.
    Græme Ravenscroft • Technical Marketing Engineer
    ('gram', like the unit of measurement)
    How can we make Arista ETM products better?


    • #3
      Thanks, I'll give that a shot. No issues going straight to 16.1.1? On debian systems I usually make sure I'm completely up to date before I upgrade distributions.


      • #4
        According to the logs above, for some reason the box cannot reach, You might look at the reports to see if something is blocking that IP.
        Attention: Support and help on the Untangle Forums is provided by
        volunteers and community members like yourself.
        If you need Untangle support please call or email [email protected]


        • #5
          Originally posted by soapee01 View Post
          No issues going straight to 16.1.1? On debian systems I usually make sure I'm completely up to date…
          You are; there's no release version after 16.0.1. Also, the NGFW itself would go straight to 16.1.1 if the upgrade were working, so you're just doing what the unit itself would do.
          Græme Ravenscroft • Technical Marketing Engineer
          ('gram', like the unit of measurement)
          How can we make Arista ETM products better?


          • #6
            It appears the issue was /etc/apt/sources.list.d/untangle.list was set to use HTTP instead of HTTPS. The repositories no longer use HTTP.

            Changing over to https seems to resolve the issue. I'm running a from the command line now.

            cat /etc/apt/sources.list.d/untangle.list
            ## Auto Generated on 2023-02-02 15:56:44.000024
            ## DO NOT EDIT. Changes will be overwritten.
            deb https://e753-4fc8-4f2d-6752:untan[email protected]/public/buster stable-160 main non-free​


            • #7
              Changing to HTTPS worked. Now I'm on 16.1.1 and continuing upgrades.


              • #8
                FYI, I did exactly the same and managed to upgrade from 16.5.2 to 16.6.2
                The http link had issues and tested it even from my laptop (opening from browser) at different location, the https worked just fine