No announcement yet.

DNS connection problem using DHCP

  • Filter
  • Time
  • Show
Clear All
new posts

  • DNS connection problem using DHCP


    I recently acquired a Untangle Z4. I've run the configuration wizzard and everything seems straightforward, but I dont have an internet connection. Running the connectivity test, it appears my ISP DNS is not working.

    The WAN port of the Z4 is connected directly to my modem which is provided by my ISP.
    The Z4 is configured in "Router" mode from the wizzard

    Port 1: WAN, DHCP, public IP succesfully obtained, primary and secondary DNS server IP adress obtained
    Port 2: Static IP with DHCP server running

    From the "Ping Test", I can succesfully ping or, so from my understanding something is wrong with the DNS. I called my ISP and from their end everything seems fine.

    I tried resetting the factory parameters and starting new, but that also did not work.

    I tried setting the Primary DNS Override to and Secondary DNS Override to in the interface 1 configuration without any luck.

    Click image for larger version

Name:	image.png
Views:	253
Size:	50.6 KB
ID:	396347
    This works both for and
    Click image for larger version

Name:	image.png
Views:	115
Size:	25.3 KB
ID:	396348

    Click image for larger version

Name:	image.png
Views:	114
Size:	23.5 KB
ID:	396349​​​

    I tried looking for an answer online or on the forum without any luck. Any help will be greatly appreciated, thank you!

  • #2
    Ping is a start but not a test for DNS. Can you ping their DNS IPs? Try running on the command line: host and host . Post the results.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email [email protected]


    • #3
      Anytime you connect a new router to a modem. You need to power cycle the modem. If you have not done this already, then I would try it.


      • #4
        It turned out some files were corrupted on the device. A fresh install has solved this problem. Thanks everyone for the help!