No announcement yet.

Untangle in Bridge Mode - Open VPN Does not Connect

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Untangle in Bridge Mode - Open VPN Does not Connect

    I have setup Untangle Server ( Latest Version ) and cannot connect with VPN (Remote OS is Vista )

    Error on Client
    Wed Feb 03 21:26:18 2010 OpenVPN 2.1_rc19 i686-pc-mingw32 [SSL] [LZO2] [PKCS11] built on Jul 16 2009
    Wed Feb 03 21:26:18 2010 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
    Wed Feb 03 21:26:18 2010 LZO compression initialized
    Wed Feb 03 21:26:18 2010 UDPv4 link local: [undef]
    Wed Feb 03 21:26:18 2010 UDPv4 link remote: Public IP :1194
    Wed Feb 03 21:27:18 2010 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    Wed Feb 03 21:27:18 2010 TLS Error: TLS handshake failed
    Wed Feb 03 21:27:18 2010 SIGTERM[soft,tls-error] received, process exiting

    Configuration is as Follows

    BT DSL Modem --> Netgear FVX538 (Router/Firewall) -->Untangle Bridge --> Lan Switch

    DSL Connected to Router Firewall WAN1
    Public Address on Router/Firewall
    Untangle External Connected Firewall LAN Port ..
    Untangle Internal Connected to Lan Switch

    Network IP - /24
    Untangle IP -
    GW - ( Netgear Router ) ..

    All conenctivity works fine - internal to External and Vice Versa.. ( IE internet email )

    I have enabled the Web Filter and Protocal Filter and both working .. so network connections for the Bridge would suggest to be correct

    I have configured the OpenVPN as per Open Wiki .. also enabled the Untanlgle Bridge to Use the External Address and Rebooted ..

    I have tried various Networks to Export .. the Default also

    Added a port forward on Netgear Router ( UDP)
    Port 1194 - to ( Untangle ) ..
    and the 192 network ..

    Just cannot connect with VPN ( I am using Vista Client ) ..

    From the Firewall I can ping
    But Tracert shows to displays nothing
    I checked the Firewall Logs - Firewall accepted from Remote to pass onto ..
    have disabled the UAC on vista and logged in administrator .. Installed and ran the OpenVpn Client .. Same error occured ..

    The Router has both 1194 and 443 directed to ..
    I have created the static route on the FW to port forward to

    The FW logs is as follows

    2010 Feb 4 14:18:01 [Name of FW] [kernel] WAN2LAN[ACCEPT] IN=WAN OUT=LAN SRC=My IP DST= PROTO=UDP SPT=22049 DPT=1194

    Looks like the FW is accepting Traffic but maybe Untangle rejecting it .. Any logs on the Untangle SRV i can view .. Unless I have missed anything else ..


  • #2
    create a VPN user for me and send it to the untangle's support email. I will see if I can connect.
    to be understood, you must first understand. :)
    Attention: Support and help on the Untangle Forums is provided by volunteers and community members like yourself. If you need Untangle support please call or email [email protected]


    • #3
      Problem now resolve thanks to Untangle Support Engineer ..

      Configuration was correct as I explained however ;

      I connected the Untangle EXT Nic to the Firewall Network Port and INT nic to the Internal Switch .. outgoing connectivity was fine as I could connect to the Internet and the Web Filter Was working ..

      Engineer Advised identified the cables are reversed during the packet capture ..

      Now the EXT Nic is connected to the LAN Switch and the INT Nic to the Firewall Network Port .. and Now I have VPN .. Thanks to Untangle Engineer