No announcement yet.

OpenVPN search domain resolved. Here how.

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • OpenVPN search domain resolved. Here how.

    In order to get the search domain past to te client a change must be made to the /etc/penvpn/server.conf file. The problem is that untangle is constantly rewriting this file on any change to the vpn. The command that passes the search domain is

    push "dhcp-option DOMAIN your.domain"

    This needs to be inserted with the other nerwork exports. To make the change sticky add this line to the openvpn start up script usr/share/untangle/openvpn/start-openvpn

    insert this line

    sed -i -e 's@# Exports@# Exports\npush "dhcp-option DOMAIN your.domain"@' /etc/openvpn/server.conf

    right after

    echo "Starting the openvpn server"

    The OpenVPN is working great now. This setting really should be made available from the gui.

    Thanks I hope this helps.

  • #2
    Thanks for the very informative and helpful post. Pushing the search domain is important for us as well. I hope that this is rolled into the main GUI.
    Founded 1978, Innovative Routines International -- a/k/a IRI, The CoSort Company -- is a US data management ISV renowned for fast data manipulation and robust data masking solutions. Headquartered in Melbourne, Florida, IRI is represented in 40 cities worldwide. IRI customers are in many industries, and have large or sensitive data in different sources they need to process or protect, present or prototype. Powered by IRI CoSort or Hadoop engines, the IRI Voracity data management platform combines data discovery, integration, migration, governance, and analytics in a single pane of glass, built on Eclipse. Voracity includes products in the IRI Data Manager suite [CoSort, Fast Extract (FACT), NextForm and RowGen] and the IRI Data Protector suite [FieldShield, CellShield EE, and DarkShield] provide multi-source data profiling and classification, fast data transformation and migration, data warehouse and analytic data wrangling, data cleansing and PII masking, and realistic test data.


    • #3
      I STILL have to do this after every untangle update. (Just updated to 7.1.1 this weekend).

      I have the correct domain name in Configuration -> Networking -> Hostname but it still doesn't push the DNS suffix, which basically stops about 80 people from getting to our intranet website. A bit of a headache. The fix is quick and easy now, but I still get tons of people telling me about, and it takes longer to answer everyone than to fix the problem.

      Any thoughts on what I should be looking at?

      Just for giggles I retyped the hostname and resaved, maybe it was a configuration file snafu that might be resolved by rewriting it? *shrug*