No announcement yet.

Legrand WWRL10 Issues with Untangle

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • Legrand WWRL10 Issues with Untangle

    Anyone have experience with Legrand WWRL10 Smart Light Switches?

    When I first got this switch back in Nov 2018, I got it setup with no issues. But every few days it would loose connection to Google Home/the Legrand App. Had to constantly reset the device via Circuit Breaker.

    Fast forward to now, I worked with their Tech Support, they are blaming my Router (Untangle) and/or Wireless (Unifi). I've turned off all Apps on Untangle and still can't get it to connect to the Samsung Artik Cloud (Legrand uses them). It just fails.

    They sent me a replacement device under warranty and the same happens. The stupid part is, I don't know know what the MAC Address of their switch is. No label or anything on the device or box for me to look into the logs of Untangle.

    Maybe I need to get a dumb router and try without Untangle in the picture. Hope someone will be able to assist me.


  • #2
    While not directly related to your issue, I have had issues connecting to my IoT sprinkler controller. It is connected to 2.4Ghz SSID while my phone is on 5Ghz. Sometimes I fail to connect to the device but can always connect if I switch to the same SSID has the controller.
    Attention: Support and help on the Untangle Forums is provided by
    volunteers and community members like yourself.
    If you need Untangle support please call or email [email protected]


    • #3
      Hi J,

      You are correct, I do have a special SSID for AUtomation stuff but it is same network as my Main SSID. But just for giggles, I connected the Smart Switch to my main SSID with the same issues after resetting it. Here is what I get when I try to re-add the device:

      Click image for larger version

Name:	Legrand1.png
Views:	1
Size:	82.4 KB
ID:	381916
      Click image for larger version

Name:	Legrand2.png
Views:	1
Size:	84.4 KB
ID:	381917

      Man what I wouldn't do to have a old Dumb Router again for testing.


      • #4
        Well I was able to get a hold of an Asus Router and it worked with no issues. Now the question is what is blocking it on Untangle when the logs show nothing being blocked. Even turning off all Applications still does not allow it to work.

        Any suggestions I'm open too.